Opened 4 months ago

Closed 2 months ago

#1646 closed defect (duplicate)

ck-macros egg tests fail due to unknown ck-wrapper identifier

Reported by: sjamaan Owned by:
Priority: major Milestone: 5.2
Component: unknown Version: 5.1.0
Keywords: Cc:
Estimated difficulty: medium

Description

I noticed in today's Salmonella run that the ck-macros egg no longer passes its tests.

This is probably caused by f43fb51ea3838cccd62b613cf82b3625809a9f93, but the question is whether this just exposes a pre-existing bug in the egg (which I consider quite likely, especially considering this is the only egg that broke) or if it's a regression.

Change History (2)

comment:1 Changed 3 months ago by sjamaan

As I suspected, it's a bug in the egg. It included the file which provides ck-wrapper in a begin-for-syntax block. This is a helper procedure which is used by macros, but it is also exposed to the user. Because the module does an implicit export of everything via *, it only failed in the tests.

I submitted a requested to fix this.

comment:2 Changed 2 months ago by sjamaan

Resolution: duplicate
Status: newclosed

Not a blocker for 5.2; this is a bug in the egg and I filed a merge request there so this doesn't have to clutter up our Trac.

Note: See TracTickets for help on using tickets.