Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#1584 closed defect (fixed)

installing srfi-13 on win8 fails (MAX_PATH is too low)

Reported by: kristianlm Owned by:
Priority: major Milestone: 5.1
Component: core tools Version: 5.0.0
Keywords: Cc:
Estimated difficulty:

Description

I am running C5 on win8 and ran into this: chicken-install srfi-13 says "cannot create subprocess".

It is caused by a MAX_PATH being too low.
chicken-do.c uses MAX_PATH to set total cmd length. my win8 MAX_PATH is 260, but my cmdline (including arguments) is longer.

If I replace MAX_PATH with 4096, it works.

Change History (3)

comment:1 Changed 3 months ago by sjamaan

  • Component changed from unknown to core tools
  • Milestone changed from someday to 5.1

comment:2 Changed 3 months ago by evhan

  • Resolution set to fixed
  • Status changed from new to closed

Thanks Kristian! Happily this it has already been fixed in 1e006b65 and will be included in the next release (I ran into it as well).

comment:3 Changed 3 months ago by kristianlm

Ah, now that's a proper fix. Thanks!

Note: See TracTickets for help on using tickets.