Opened 21 months ago

Closed 5 months ago

#1426 closed defect (worksforme)

test-finalizers may break in interpreted mode when importing posix

Reported by: sjamaan Owned by: felix winkelmann
Priority: major Milestone: 5.1
Component: core libraries Version: 5.0.0
Keywords: gc, finalizers Cc:
Estimated difficulty: insane

Description

I've seen the final assertion in tests/test-finalizers.scm fail under CHICKEN 5 when you add (import (chicken posix)) to the top.

It fails because n has value 0 at the end instead of the expected 1, which means the bump procedure (which is registered as a finalizer on the string constant) wasn't run.

I haven't been able to reproduce this consistently, so this may also affect CHICKEN 4.

Change History (4)

comment:1 Changed 21 months ago by sjamaan

Owner: changed from sjamaan to felix winkelmann
Status: newassigned

comment:2 Changed 21 months ago by felix winkelmann

I can not reproduce this. I tried changing the nursery size, but nothing happens.

If someone can, try replacing the final constant string with something dynamically generated (say, (make-string 100)). Does the error still occur?

comment:3 Changed 21 months ago by felix winkelmann

Milestone: 5.05.1

comment:4 Changed 5 months ago by sjamaan

Resolution: worksforme
Status: assignedclosed

Let's ignore this for now. It might've been accidentally fixed or not, but if we can't reproduce it it makes no sense to keep this ticket open. We may re-open it later. I've added a comment to the test so we can find the ticket again.

Note: See TracTickets for help on using tickets.