Opened 2 years ago

Last modified 15 months ago

#1220 reopened defect

Problems with chicken-status -f after using chicken-install -p

Reported by: ryuslash Owned by: ckeen
Priority: minor Milestone: someday
Component: unknown Version: 4.10.x
Keywords: Cc:
Estimated difficulty: medium

Description

Hi,

When I use chicken-install -p to install an extension library to a non-default location and then move it to where all other extension libraries are installed, calling chicken-install -f on it produces the wrong results.

For example:

$ chicken-install -r xlib-utils
$ cd xlib-utils && mkdir foo
$ chicken-install -p foo
$ sudo mv foo/lib/chicken/7/* /usr/lib/chicken/7/
$ chicken-status -f xlib-utils
/home/slash/xlib-utils/foo/home/slash/xlib-utils/foo/lib/chicken/7/xlib-utils.import.so
/home/slash/xlib-utils/foo/home/slash/xlib-utils/foo/lib/chicken/7/xlib-utils.so

This is wrong for two reasons:

  1. The files have been moved to /usr/lib/chicken/7/
  2. The path /home/slash/xlib-utils/foo/home/slash/xlib-utils/foo/lib/chicken/7/ never existed, it was /home/slash/xlib-utils/foo/lib/chicken/7/.

I packaged some extension libraries for the Archlinux User Repository and this is basically how packages are made, they are installed in a kind of staging area and then later put in the proper place from the package.

Everything still seems to work fine, programs depending on extension libraries installed this way don't seem to have any trouble with it, even when I remove the directory where the files were stored before being packaged.

Change History (6)

comment:1 Changed 2 years ago by ckeen

  • Owner set to ckeen
  • Status changed from new to assigned

comment:2 Changed 2 years ago by ckeen

Yes the path is wrong completely. I am not sure what to do about the moving part. Maybe we can make the path relative to the current repository-path? The info files are only searched there and the path could be converted to an absolute one wherever needed.

Opinions from the others?

comment:3 Changed 2 years ago by ckeen

I have a fix and will push it once I can get online again.

comment:4 Changed 2 years ago by ckeen

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed by d90426a on chicken master and ad0bc66 on chicken-5.

comment:5 Changed 17 months ago by ryuslash

  • Resolution fixed deleted
  • Status changed from closed to reopened

I have just tried this with chicken 4.11.0 and it hasn't been fixed it seems.

comment:6 Changed 15 months ago by sjamaan

  • Estimated difficulty set to medium
Note: See TracTickets for help on using tickets.