Opened 2 years ago

Closed 4 weeks ago

#1193 closed defect (fixed)

Ambiguity in csc's command line options

Reported by: mario Owned by:
Priority: major Milestone: 5.0
Component: core tools Version: 4.9.x
Keywords: command line parser, csc Cc:
Estimated difficulty: medium

Description

csc supports -l<libname> to link programs against lib<libname> on unix. The problem is that csc also accepts some other options that start with -l: -local, -lfa2, -library, -ld, -ldflags, -libs and -ld-name.

So, if we ever need to use csc to link programs against libocal, libfa2, libibrary, libd, libdflags, libibs or libd-name, we'll have ambiguities on the command line.

Change History (2)

comment:1 Changed 15 months ago by sjamaan

  • Estimated difficulty set to medium

comment:2 Changed 4 weeks ago by sjamaan

  • Resolution set to fixed
  • Status changed from new to closed

Fixed by 8553c4c2f0b51c836b9486d8fef96a5656b3cdd4

Note: See TracTickets for help on using tickets.