Opened 4 years ago

Closed 4 years ago

#1184 closed defect (fixed)

lowdown: Error: (car) bad argument type: ()

Reported by: mario Owned by: syn
Priority: major Milestone: someday
Component: extensions Version: 4.9.x
Keywords: lowdown Cc:
Estimated difficulty:

Description

Bug?

$ csi -nq
#;1> (use lowdown)
...
#;2> (markdown->sxml "(define-page (irregex \"/foo/[]*\") identity)")

Error: (car) bad argument type: ()

        Call history:

        <syntax>          (markdown->sxml "(define-page (irregex \"/foo/[]*\") identity)")
        <eval>    (markdown->sxml "(define-page (irregex \"/foo/[]*\") identity)")      <--

$ chicken-status lowdown
lowdown ....................................................... version: 0.0.8
$ chicken -version
(c) 2008-2014, The Chicken Team
(c) 2000-2007, Felix L. Winkelmann
Version 4.9.0.1 (stability/4.9.0) (rev 8b3189b)
linux-unix-gnu-x86-64 [ 64bit manyargs dload ptables ]
bootstrapped 2014-06-07

Change History (1)

comment:1 Changed 4 years ago by syn

  • Resolution set to fixed
  • Status changed from new to closed

This was caused by the "[]" which was parsed as an empty reference link. I just released Lowdown 0.0.9 which fixes this issue. Thanks for reporting it!

Note: See TracTickets for help on using tickets.