Opened 4 years ago

Closed 4 years ago

#1160 closed defect (fixed)

typed-lists: tests fail sometimes

Reported by: mario Owned by:
Priority: major Milestone: someday
Component: extensions Version: 4.9.x
Keywords: typed-lists Cc:
Estimated difficulty:

Description

Some examples this month:

The error is:

Error: (import) during expansion of (import ...) - during expansion of (import ...) - cannot import from undefined module: M

Maybe it is related to a functors issue you reported some time ago? I wonder why it works sometimes.

Change History (3)

comment:1 Changed 4 years ago by juergen

It's caused by a bug in the functor implementation: The csc generated import files refer to the module parameter, e.g. M, not the module argument, e.g. nums, as it should be. The typed-lists egg contains a patch to be applied to the import files.
In interpreted mode there is no problem, hence the tests fail only sometimes.

comment:2 Changed 4 years ago by mario

  • Owner juergen deleted
  • Status changed from new to assigned

comment:3 Changed 4 years ago by mario

  • Resolution set to fixed
  • Status changed from assigned to closed

This issue has probably been fixed by 4e3d990030e490bb8fb489e731b2f9c5e23eaded (master) and 9808ec07e10b7a48f685ac09d27bf22ae5abbcd3 (chicken-5), since the same fix for #1149 applies.

Note: See TracTickets for help on using tickets.