Opened 3 years ago

Closed 7 weeks ago

#1156 closed defect (fixed)

compiler warnings when import specifiers are used for setup-api and setup-download

Reported by: mario Owned by:
Priority: minor Milestone: 5.0
Component: unknown Version: 4.9.x
Keywords: setup-api, setup-download, import specifiers Cc:
Estimated difficulty: medium

Description

Here are some examples:

$ echo '(module sa () (import chicken scheme) (use (only setup-api version>=?)))' > sa.scm                                       

$ csc sa.scm 

Warning: extension `setup-api' is currently not installed


$ echo '(module sa () (import chicken scheme) (use (except setup-api version>=?)))' > sa.scm                                     

$ csc sa.scm 

Warning: extension `setup-api' is currently not installed


$ echo '(module sa () (import chicken scheme) (use (except setup-download latest-version)))' > sa.scm

$ csc sa.scm 

Warning: extension `setup-download' is currently not installed

However,

$ echo '(module sa () (import chicken scheme) (use setup-api))' > sa.scm
$ csc sa.scm 

produces no warning.

Change History (3)

comment:1 Changed 21 months ago by sjamaan

  • Milestone changed from someday to 5.0

CHICKEN 5's module stuff has been made more strict, so maybe we can take a look at that. Also, the first example breaks on CHICKEN 5!

comment:2 Changed 9 months ago by sjamaan

  • Estimated difficulty set to medium

comment:3 Changed 7 weeks ago by sjamaan

  • Resolution set to fixed
  • Status changed from new to closed

I can't reproduce this anymore in CHICKEN 5. The module stuff has been changed quite a bit, so it's likely that one of those commits has resolved the issue.

Note: See TracTickets for help on using tickets.