Opened 6 years ago

Closed 6 years ago

#1137 closed defect (fixed)

sql-de-lite: use of ##sys#expand-home-path

Reported by: Mario Domenech Goulart Owned by: Jim Ursetto
Priority: major Milestone: someday
Component: extensions Version: 4.9.x
Keywords: sql-de-lite Cc:
Estimated difficulty:

Description

##sys-expand-home-path has been removed from CHICKEN (4f91e654f04254ba1039e327460e643fefbf5e36), but sql-de-lite still uses it:

$ grep -n expand-home sql-de-lite.scm 
789:             (##sys#expand-home-path filename)
796:      (let* ((rv (sqlite3_open (##sys#expand-home-path filename)

It is probably the cause of test failures for sql-de-lite itself, ugarit, sqdb and nomads (see http://salmonella-linux-x86-64.call-cc.org/master-debugbuild/gcc/linux/x86-64/2014/07/02/yesterday-diff/)

Change History (1)

comment:1 Changed 6 years ago by Jim Ursetto

Resolution: fixed
Status: newclosed

Fixed in sql-de-lite 0.6.3 by removing the call to ##sys#expand-path, in favor of requiring the user to use something like the pathname-expand egg on the argument. Assuming it doesn't break anyone's code... but this feature was not documented.

Note: See TracTickets for help on using tickets.