Opened 6 years ago

Closed 6 years ago

#1133 closed defect (fixed)

segfault violation when using tcp-accept (as last s-exp?)

Reported by: kristianlm Owned by:
Priority: critical Milestone: someday
Component: core libraries Version: 4.9.x
Keywords: Cc:
Estimated difficulty:

Description (last modified by sjamaan)

As shown in this paste,

http://paste.call-cc.org/paste?id=bfe5899d243035a1a5a67f48b97675dbc3405458

$ cat foo.scm
(use tcp srfi-18)
(tcp-accept (tcp-listen 1230))
$ csc foo.scm && ./foo &
[1] 5449
$ nc localhost 1230

Error: segmentation violation

	Call history:

	foo.scm:2: tcp-listen	  
	foo.scm:2: tcp-accept	  	<--
[1]+  Exit 70                 ./foo

This works from csi -s foo.scm.

Change History (3)

comment:1 Changed 6 years ago by sjamaan

Description: modified (diff)

This is similar to #999, and actually caused by the fix for that ticket :)

comment:2 Changed 6 years ago by sjamaan

Description: modified (diff)

A workaround for this problem (if it ever occurs in practice) is to add (use ports) to the program (or even (require-library ports) if you're paranoid about not importing anything you're not using).

comment:3 Changed 6 years ago by sjamaan

Resolution: fixed
Status: newclosed

Fixed by a25d2006bdbcd794a5ce3002c04b618f35667f7c, will appear in 4.9.0.2

Note: See TracTickets for help on using tickets.