Opened 6 years ago

Closed 6 years ago

#1118 closed defect (wontfix)

parley: Arrow key cursor movement doesn't work in csi with urxvt

Reported by: acharlton Owned by: Christian Kellermann
Priority: minor Milestone: someday
Component: extensions Version: 4.8.x
Keywords: Cc:
Estimated difficulty:

Description

Using parley with csi in the following fashion:

(use parley)
(let ((old (current-input-port)))

(current-input-port (make-parley-port old)))

Running csi in urxvt and attempting to move the cursor with arrow keys results in a character being printed (A, B, C, or D). Cursor movement with Ctrl-A,E,N,P works. Curiously, Ctrl-arrow-keys result in lowercase characters being printed (a, b, c, and d).

This does not affect other terminals that I've tried, only urxvt (rxvt-unicode).

Change History (3)

comment:1 Changed 6 years ago by Christian Kellermann

Owner: set to Christian Kellermann
Status: newaccepted

comment:2 Changed 6 years ago by Christian Kellermann

Can you please give me more information about the versions you have used?

I have tried to reproduce the problem on a 64bit linux debian stable using rxvt-unicode (urxvt) v9.15 - released: 2012-01-21

with CHICKEN 4.9.1 and parley 0.8.1 and the csirc snippet you provided.

What I did:

  1. run urxvt
  2. start csi inside
  3. type something
  4. move error keys -> works as expected

comment:3 Changed 6 years ago by Christian Kellermann

Resolution: wontfix
Status: acceptedclosed

After our discussion on IRC I checked with your old mint 12 and could not reproduce the issue since rxvt-unicode DEBs are not available anymore. Mint 16, the current version, does not show the issue and works as expected. I am closing this bug now, since I cannot reproduce it.

Note: See TracTickets for help on using tickets.