Opened 6 years ago

Closed 6 years ago

#1089 closed defect (fixed)

parametric-curve: Error: assertion failed: (every (lambda (x y) (< (abs (- x y)) 1e-15)) ((sample-curve my-scaled-c) 5) (list 3.0 4.0 25.0))

Reported by: Mario Domenech Goulart Owned by: Ivan Raikov
Priority: major Milestone: someday
Component: extensions Version: 4.8.x
Keywords: parametric-curve Cc:
Estimated difficulty:

Description

This one looks a little tricky: tests fail on the new salmonella VM, but succeed on the current one.

On the new salmonella VM: http://salmonella-linux-x86.call-cc.org/master-debugbuild/gcc/linux/x86/2014/01/18/salmonella-report/test/parametric-curve.htmlz

On the current salmonella VM: http://tests.call-cc.org/master/linux/x86/2014/01/18/salmonella-report/test/parametric-curve.htmlz

There probably are differences in the system package versions, but I don't know if it is relevant.

Change History (3)

comment:1 Changed 6 years ago by Ivan Raikov

Thanks for the report. This egg relies in bvsp-spline, which in turn relies on the f2c library, so it is possible that a difference in the system libraries is the cause. Can you tell me the OS versions of the old and new machines and the versions of gcc and f2c installed?

comment:2 Changed 6 years ago by Mario Domenech Goulart

On the current machine:

  • f2c 20100827-1
  • gcc 4.6.2

On the new machine:

  • f2c 20100827-1
  • gcc 4.6.3

The default gcc version on the new machine is actually 4.7.2, but we had to switch to 4.6.3 because 4.7.2 has what we suppose to be a code generation issue (see #916). Maybe f2c has some dependency on the default gcc version (4.7.2)?

comment:3 Changed 6 years ago by Ivan Raikov

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.