Opened 8 years ago

Closed 8 years ago

#1058 closed defect (fixed)

Strange bugs in openssl egg (or core?)

Reported by: sjamaan Owned by: Thomas Chust
Priority: major Milestone: 4.9.0
Component: unknown Version: 4.8.x
Keywords: crash, panic, openssl Cc:
Estimated difficulty:

Description

We've seen that henrietta-cache occasionally, but consistently shows strange behaviour. It appears this happens only for HTTPS URIs, so I've done some investigating and can reproduce a situation which could be related:

(use http-client extras)

(let lp ()
  (print (with-input-from-request (car (command-line-arguments)) #f read-file))
  (lp))

Just call the program like this:

csi -s foo.scm https://bitbucket.org/sjamaan/henrietta-cache/raw/tip/henrietta-cache.release-info

Then press ^C after the program has seemed to make a connection.

You'll generally get a panic in the scheduler that says "fdset-set: invalid i/o direction: ssl-mutex (fd = 15)" (with today's master; before you just got the message without more info). It appears the ssl-mutex somehow ends up in the fd-set upon which the thread will wait for I/O. This is most likely due to some corruption elsewhere, but it's unclear where exactly.

This may be related to #989 (ie, it could be a signal handling issue). Mario has http://paste.call-cc.org/paste?id=3afab8fc3c4af312b5b0711cee1b922620b5ad7e#a1 observed occasional segfaults instead of panics.

Change History (2)

comment:1 Changed 8 years ago by sjamaan

The bug is in CHICKEN core. Patch forthcoming

comment:2 Changed 8 years ago by sjamaan

Resolution: fixed
Status: newclosed

Fixed by changeset 4c14161ba09eb1f875c40dfa0d722382fad98f36

Note: See TracTickets for help on using tickets.