Changeset 35744 in project


Ignore:
Timestamp:
07/05/18 04:02:18 (2 weeks ago)
Author:
kon
Message:

boing

Location:
release/4/apropos/trunk
Files:
1 added
3 edited

Legend:

Unmodified
Added
Removed
  • release/4/apropos/trunk/apropos-srfi-csi.scm

    r35743 r35744  
    55
    66(;export
    7   srfi-srfis
    8   srfi-info
    9   srfi-alist
    10   ;
    117  srfi-features)
    128
     
    1814  (only ports with-input-from-string)
    1915  (only utf8-srfi-13 string-trim-both)
    20   apropos-srfi)
    21 
    22 (reexport apropos-srfi)
     16  (only feature-utils sorted-feature-srfis)
     17  (only apropos-srfi srfi-info srfi-srfis))
    2318
    2419;;; String Utilities
     
    4742;;
    4843
    49 (define srfi-features (make-parameter '(0)
     44(define srfi-features (make-parameter (sorted-feature-srfis)
    5045  (lambda (x)
    5146    (if (list? x)
  • release/4/apropos/trunk/apropos.meta

    r35743 r35744  
    1818  "apropos.scm"
    1919  "apropos-srfi.scm" "apropos-srfi-csi.scm" "apropos-srfi-db.scm"
     20  "feature-utils"
    2021  "tests/run.scm" "tests/apropos-test.scm"
    2122  "tests/apropos-srfi-test.scm") )
  • release/4/apropos/trunk/apropos.setup

    r35743 r35744  
    33(use setup-helper-mod)
    44
    5 (verify-extension-name "apropos")
     5;;; (verify-extension-name "feature-utils" #;"1.0.0")
    66
    7 (unless (version>=? (chicken-version) "4.4.0")
    8   (enable-warnings #t)
    9   (warning "cannot use with CHICKEN earlier than version 4.4.0, install apropos:1.4.3 instead.")
    10   (exit 1) )
    11 
    12 (setup-shared-extension-module 'apropos (extension-version "2.8.0")
     7(setup-shared-extension-module 'feature-utils (extension-version "2.8.0")
    138  #:types? #t
    149  #:inline? #t
     
    3126  #:inline? #t
    3227  #:compile-options '(-O3 -d1 -no-procedure-checks))
     28
     29;;;
     30
     31(verify-extension-name "apropos")
     32
     33(unless (version>=? (chicken-version) "4.4.0")
     34  (enable-warnings #t)
     35  (warning "cannot use with CHICKEN earlier than version 4.4.0, install apropos:1.4.3 instead.")
     36  (exit 1) )
     37
     38(setup-shared-extension-module 'apropos (extension-version "2.8.0")
     39  #:types? #t
     40  #:inline? #t
     41  #:compile-options '(-O3 -d1 -no-procedure-checks))
Note: See TracChangeset for help on using the changeset viewer.