Opened 11 years ago

Closed 11 years ago

#259 closed defect (fixed)

when commiting to the svn repo, the post-commit hook seems to fail

Reported by: felix winkelmann Owned by: Mario Domenech Goulart
Priority: major Milestone:
Component: infrastructure Version:
Keywords: svn post-commit Cc:
Estimated difficulty:

Description

From a NetBSD machine:

% svn ci -m "tagged awk 1.2"
Adding         tags
Adding         tags/1.2

Committed revision 18265.

Warning: post-commit hook failed (exit code 1) with no output.

Change History (6)

comment:1 Changed 11 years ago by Mario Domenech Goulart

Resolution: worksforme
Status: newclosed

Hmmm. Weird. I can't reproduce this problem. The error you get may be because of some temporary network failure which made the connection to Moritz machine (which runs vandusen) fail.

I'll set this bug as worksforme and I'll try do do something to handle network failures better in post-commit-hook.

comment:2 Changed 11 years ago by Moritz Heidkamp

Yes, it was my fault, I crashed vandusen yesterday and was too much in a hurry to make him work again. Mario will make the hook scripts handle situtations like this more gracefully. Sorry for the noise :)

comment:3 Changed 11 years ago by felix winkelmann

Priority: majorminor
Resolution: worksforme
Status: closedreopened

Still happens.

comment:4 Changed 11 years ago by felix winkelmann

Priority: minormajor

The git hook returns with an error as well:

% git push origin experimental
Counting objects: 15, done.
Compressing objects: 100% (9/9), done.
Writing objects: 100% (9/9), 1.46 KiB, done.
Total 9 (delta 7), reused 0 (delta 0)
error: hooks/post-receive exited with error code 1
To chicken@galinha.ucpel.tche.br:chicken-core.git
   e1e8917..1dac007  experimental -> experimental

comment:5 Changed 11 years ago by Mario Domenech Goulart

I've set the SVN post-commit hook and Git post-receive hook to report success even if vandusen fails. Just tested on SVN and it seems to be working.

Let's see if this fix things.

comment:6 Changed 11 years ago by felix winkelmann

Resolution: fixed
Status: reopenedclosed

Looks good. Thanks very much, Mario.

Note: See TracTickets for help on using tickets.