Changeset 35372 in project


Ignore:
Timestamp:
04/01/18 14:53:27 (8 months ago)
Author:
sjamaan
Message:

man/5: Remove require-extension-for-syntax

File:
1 edited

Legend:

Unmodified
Added
Removed
  • wiki/man/5/Module (chicken base)

    r35281 r35372  
    12471247
    12481248
    1249 ==== require-extension-for-syntax
    1250 
    1251 <macro>(require-extension-for-syntax ID ...)</macro>
    1252 
    1253 An abbreviation for the idiom:
    1254 
    1255 <enscript highlight=scheme>
    1256 (begin-for-syntax (require-library ID ...))  ; load extension at expansion-time
    1257 (import-for-syntax ID ...)                   ; import extension for use in syntax-transformers
    1258 </enscript>
    1259 
    1260 Where {{begin-for-syntax}} is taken from the {{(chicken syntax)}} module.
    1261 
    1262 
    12631249==== require-library
    12641250
Note: See TracChangeset for help on using the changeset viewer.