Changeset 25526 in project


Ignore:
Timestamp:
11/19/11 22:02:30 (8 years ago)
Author:
Jim Ursetto
Message:

wiki/objc: Stress incompatibility with 10.6 or higher

File:
1 edited

Legend:

Unmodified
Added
Removed
  • wiki/eggref/4/objc

    r22990 r25526  
    1717This egg provides a basic interface to Objective C from Scheme.  You can invoke class and instance methods, access instance variables, and define Objective C classes directly in Scheme.
    1818
    19 This egg [[#Requirements|requires Mac OS X and libffi]].
     19This egg [[#Requirements|requires Mac OS X 10.5 ''or earlier'', and libffi]].
    2020
    2121=== Method invocation
     
    533533=== Requirements
    534534
    535 '''Mac OS X Intel or PPC'''.  This egg does not run on GNUStep.
     535'''Mac OS X Intel or PPC (10.5 or earlier)'''.  This egg does not run on GNUStep.  It also does not run on OS X 10.6 or later due to significant internal changes in Objective C, and there are no plans to make it compatible.
    536536
    537537'''libffi'''.  Chicken itself need not be compiled with libffi support; libffi just needs to be installed on your system.  Install one of these:
Note: See TracChangeset for help on using the changeset viewer.