Changeset 14599 in project for chicken/trunk


Ignore:
Timestamp:
05/12/09 06:07:55 (11 years ago)
Author:
Ivan Raikov
Message:

Fix to require-extension version to handle the case when required
version and present version are equal.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • chicken/trunk/setup-api.scm

    r14587 r14599  
    658658                 (let ((ver (and (assq 'version info) (cadr (assq 'version info)))))
    659659                   (cond ((not ver) (upgrade-message ext "has no associated version information"))
    660                          ((version>=? version ver)
     660                         ((and (version>=? version ver) (not (string=? (->string version) (->string ver))))
    661661                          (upgrade-message
    662662                           ext
Note: See TracChangeset for help on using the changeset viewer.