Changeset 11623 in project


Ignore:
Timestamp:
08/13/08 04:03:39 (12 years ago)
Author:
Ivan Raikov
Message:

Some fixed in utf8 support; version set to 2.10

Location:
release/3/pyffi/trunk
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • release/3/pyffi/trunk/pyffi-eggdoc.scm

    r11020 r11623  
    1111
    1212     (history
    13       (version "2.9" "Added support for automatic conversion of Python class instances to Scheme alists")
    14       (version "2.8" "Bug fixes in Python FFI function declarations")
    15       (version "2.7" "Bug fixes in the Python unicode string conversion routine")
    16       (version "2.6" "define-pyslot updated to support modifying attributes")
    17       (version "2.5" "Added definitions for Py_IncRef and Py_DecRef when using Python 2.3")
    18       (version "2.4" "Fixed a bug in the wrapper of PyRun_String")
    19       (version "2.3" "Added support for the boolean type")
    20       (version "2.2" "Some fixes to ensure compatibility with Python 2.3 and 2.5")
    21       (version "2.1" "Build script updated for better cross-platform compatibility")
    22       (version "2.0" "Change to use utf8 extension")
    23       (version "1.1" "Metafile fix")
    24       (version "1.0" "Initial release"))
     13      (version "2.10" "Fixes in utf8 support")
     14      (version "2.9"  "Added support for automatic conversion of Python class instances to Scheme alists")
     15      (version "2.8"  "Bug fixes in Python FFI function declarations")
     16      (version "2.7"  "Bug fixes in the Python unicode string conversion routine")
     17      (version "2.6"  "define-pyslot updated to support modifying attributes")
     18      (version "2.5"  "Added definitions for Py_IncRef and Py_DecRef when using Python 2.3")
     19      (version "2.4"  "Fixed a bug in the wrapper of PyRun_String")
     20      (version "2.3"  "Added support for the boolean type")
     21      (version "2.2"  "Some fixes to ensure compatibility with Python 2.3 and 2.5")
     22      (version "2.1"  "Build script updated for better cross-platform compatibility")
     23      (version "2.0"  "Change to use utf8 extension")
     24      (version "1.1"  "Metafile fix")
     25      (version "1.0"  "Initial release"))
    2526
    2627     (requires (url "utf8.html"   "utf8")
  • release/3/pyffi/trunk/pyffi.meta

    r9305 r11623  
     1;; -*- Hen -*-
     2
    13((egg "pyffi.egg") ; This should never change
    24
  • release/3/pyffi/trunk/pyffi.setup

    r11020 r11623  
     1;; -*- Hen -*-
    12
    23(define pyflags
     
    4243(install-extension
    4344 'pyffi
    44  `(,(dynld-name "pyffi-support") "pyffi.scm"  "pyffi.html"
     45 `(,(dynld-name "pyffi-support") "pyffi.scm" 
    4546   ,@(if has-exports? '("pyffi-support.exports") (list)) )
    46  `((version 2.9)
     47 `((version 2.10)
    4748   (syntax)
    4849   (require-at-runtime pyffi-support)
Note: See TracChangeset for help on using the changeset viewer.